Bugs in SB 4.162

  • Hi Ssnake,

    Habe 4.162 wie vorgegeben installiert. Nach öffnen des Editors musste ich Folgendes feststellen:

    1. Die Vektorlinie "Leitplanke" ist zerrissen und teilweise verschoben/versenkt:

    2. Die Stromleitung "Municipal" ist ungleichmäßig höhenmäßig versetzt, teilweise sogar verschwunden:

    3. Die Brücken haben zwar jetzt beim Editieren Pfeilersymbole, aber sie werden nichtmehr an Straßen gekoppelt:

    Dies ist bei allen gespeicherten Gelände, also von mir unveränderten Karten so. Auch bei in Arbeit befindlichen Karten ist dies der Fall.

    Wenn ich bedenke, dass ich Monate an den Karten gesessen bin ... fehlen mir die Worte!

    Die Screenshots sind aus der Map "Schwarmstedt-Bergen-Munster-Eimke".

    X(

    Gruß

  • ... und hier ein paar "Bug-Screenshots" aus den Karten "Wasserkuppe" und "Wolfsburg-Dahlum":

    1, WASSERKUPPE:

    2. Wolfsburg-Dahlum:

    Damit können viele Szenarien nurnoch bedingt bzw. zur Zeit nicht genutzt werden.


    Ich bitte dringend darum, dass dies zuvor doch getestet und überprüft wird, wenn derartige "Patch" herausgegeben werden und vorallem, dass diese Mängel umgehend abgestellt und korrigiert werden!


    Gruß

  • Ich deinstalliere 4.162 wieder und installiere eneut 4.161, denn ansonsten kann ich die Szenarien auf meinen Maps nicht verwenden.

    Ich empfehle Euch 4.162 derzeit nicht zu installieren!

    Abraxas


    Lombardi: "Wer etwas will, findet Wege; wer etwas nicht will, Gründe!"



    The post was edited 1 time, last by Abraxas: Tippfehler! ().

  • Hallo Abraxas,

    auch mir sind diese Dinge aufgefallen.

    Allerdings ist es noch komplizierter, denn die "versinkenden" Brücken sieht man nur im Gelände-Editor.

    Im Szenarien-Editor oder im Spiel sehen diese Brücken wieder normal aus.

    Hier ein Beispiel:

    Zweimal die gleiche Ansicht:



    (das sollte so nicht passieren)

    mkG

    LoneWolf

  • Hallo Abraxas,

    mir ist gerade eben noch eine Sache aufgefallen, die den Gelände-Editor noch verschlimmert.

    Ich wollte eine ausgewählte Strasse anheben (Rampe erzeugen), als ich feststellen musste, dass in der Version 4.162 jetzt plötzlilch Start und Ende vertauscht worden sind.

    Wenn man tatsächliche Höhe einschaltet, dann wird diese korrekt in die Felder eingetragen, die Rampe wird allerdings entgegengesetzt erzeugt.

    Damit ist diese Werkzeug eigentlich nicht mehr benutzbar.

    Schade!

    P.S.

    Ich werde wohl auch wieder zurück zur Version 4.161 gehen.

    mkG

    LoneWolf

  • Das mit dem Rampenbau ist natürlich extrem ärgerlich, und natürlich kann man auch mit den anderen Punkten nicht zufrieden sein. Allerdings glaube ich, daß es objektiv nicht gar so schlimm ist. Soweit eine Karte bereits veröffentlicht ist, kann man in ihr sowieso nicht mehr gärtnern. Nimmt man eine Karte, die noch in Bearbeitung ist, kann man die schiefen (alten) Brücken getrost ignorieren. Sieht zwar scheiße aus, aber im Szenario ist es ja nicht so, und wenn man jetzt im Karteneditor alle neuen Brücken schön ausrichtet, dann sollten auch die im Szenario gut funktionieren. Insofern ist es ein - wenn auch extrem ärgerliches - kosmetisches Problem, daß mit dem nächsten Update (es wird eins geben) natürlich behoben werden wird.


    Ich verstehe natürlich, wenn man stattdessen lieber weiter 4.161 verwendet, speziell wenn die Verbesserungen von 4.162 nicht so dringend erscheinen. In den nächsten fünf Monaten oder so dürfte es noch ein größeres Update geben, daß dann hoffenlich diese Macken auch ausbügelt.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Wie es aussieht, sind die vermackelten Brücken im Geländeeditor ein Nebeneffekt der Beseitigung von Fehler Nr. 8130, der erst vor relativ kurzer Zeit entdeckt wurde (wie man aufgrund der hohen "Seriennummer" erkennen kann, aktuell sind wir bei Nr. 8139). Wie auch immer, ich hatte den Prüfauftrag für die Betatester - viele machen das noch immer freiwillig, und das kurz vor Weihnachten - auf die Frage beschränkt, ob 4.162 in Summe besser ist als 4.161, als das zentrale Kriterium für die Frage: Veröffentlichen oder nicht?

    Das mußten wir so machen, weil wir ohne den Patch 4.162 eine Reihe neuer Features nicht integrieren könnten, die wir für andere Projekte integrieren müssen (und die auch die Grundlage für das Update in den kommenden Monaten sein werden).


    Dies nur als Hintergrund. Auch wenn wir den Fehler, der zu den schief dargestellten Brücken führt, recht schnell beheben werden, werden wir höchstwahrscheinlich dennoch keinen "Patch 4.162a" oder ähnlich herausbringen können, ganz einfach weil die neuen (noch experientellen) Funktionen nun den Programmzweig 4.1 "kontaminiert" haben.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Dann warte ich und wahrscheinlich Einige ein paar Monate auf 4.163(?), so es diesmal hoffentlich fehlerfrei ist. 4.161 funktioniert ja!


    Einen schönen 4. Advent, eine friedvolle, gesegnete Weihnacht und einen guten Rutsch ins Neue Jahr wünsche ich Dir und dem SB-Team!

    mkG

  • Hallo,

    mir ist beim "Probefahren" in einer neuen Karte (mit Über- und Unterführungen) aufgefallen, dass bei Marschrouten, die entlang von Eisenbahnschienen unter Brücken verlaufen, die Fahrzeuge (egal welche) unter den Brücken stoppen und versuchen seitlich in den Damm nach oben zu fahren.

    (Festgestellt nicht nur an der oben abgebildeten Brücke)

    Das macht es für den Szenarioentwickler schwierig bis unmöglich vernünftige Annäherungen zu gestalten.

    (Ich habe das bei Version 4.161 noch nicht getestet!)

    mkG

    LoneWolf

    PS.

    Allen einen schönen 4. Advent und Frohes und Friedvolles Weihnachtsfest!

    LoneWolf

  • Ich habe dies auf meinen Karten getestet und es ist ein Unterfahren stets möglich. Voraussetzung war/ist, dass die Durchfahrtshöhe so gewählt und gebaut ist, dass bei Fahrzeugen kein "festes Teil" (Turm, Scheinwerfer, MG) anstößt. Antennen können vernachlässigt werden. Bei Brückenlegepanzern tritt ggf. ein kurzeitiges "Abklappen" der Schnellbrücke auf. Schaut zwar doof aus, behindert aber nicht die Bewegung!

  • mir ist ... aufgefallen, dass bei Marschrouten, die entlang von Eisenbahnschienen unter Brücken verlaufen, die Fahrzeuge (egal welche) unter den Brücken stoppen und versuchen seitlich in den Damm nach oben zu fahren.

    Das kann alle Kreuzungsarten betreffen. An speziell diesem Problem arbeitet einer unserer Programmierer gerade. Es tritt aber meines Wissens nach nur dann auf, wenn man den Pfad per Shift+Klick durch die Unterführungen legt. Wenn man nun kurz vor der Brücke einen Wegpunkt kreiert, dann durch die Brücke mit Alt+Klick eine gerade Verbindung zur anderen Seite legt (Wegpunkt), und anschließend normal weitermacht, sollte es klappen.


    Ich empfehle ohnehin, wenigstens alls 500...700m einen Wegpunkt anzulegen. Das gibt einem mehr Flexibilität später, sollte man mittendrin eine Umfahrung oder solnstige Alternativroute (Formations-/Taktikwechsel) einplanen müssen.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Kameraden,

    die Version 4.162 habe ich installiert und bereits Scenarios gefahren. Was auch noch geschlüsselt werden kann, sind die Artillerie-Feuerräume/ Feuerführungskonzept.


    Die geplanten Feuer werden nicht mehr auf der Karte angezeigt. Ich legen mir jeweils ein kleines Feuerführungskonzept an. Dies zeigt, wo ich blenden, niederhalten oder zerschlagen will.

    Was optimal wäre ist, dass die geplanten Feuer inkl. deren Ausdehnung (z. B 350x400) auch gestrichelt auf der Karte angezeigt würde. In einer ganz früheren Version wurden diese Artillerie-Feuerräume jeweils gestrichelt mit Zeitangabe angezeigt.






    Dies eine Anmerkung zur Optimierung.


    Grüsse aus Bern und wünsche allen schöne und geruhsame Festtage.



    sigi

  • Ist eine Frage des gewählten Realismus-Grads. Auf Mittel und Niedrig sollten die Aufträge in der Kartenansicht sichtbar sein. Leider führte das immer wieder zu Feuerkorrekturen von der Karte statt durch den Beobachter, daher haben wir's im höchsten Realismus-Grad abgeschaltet.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Da ich gerne weitergärtnern wollte, aber auch online Gefechte fahren wollte, habe ich nunmehr folgenden "Trick" angewendet:

    - 4.161 war ja installiert;

    - zunächst das Desktop Symbol von SB umbenannt in "Steel Beasts 4.161";

    - nun habe ich 4.162 unter das Verzeichnis: "C:/Programme/eSim Games/SB Pro PE 4162" hinzu installiert, wobei ich "4162" im Zielortnamen einfach ergänzt habe;

    - das DeskTop Symbol anschließend umbenannt in "Steel Beasts 4.162"

    Nun ausprobiert und siehe da, alles funktioniert einwandfrei!

    + unter 4.161 kann ich wie gewohnt in meinen Karten gärtnern und alles wird einwandfrei angezeigt!

    + unter 4.162 kann ich auf den vorhandenen und abgeschlossenen Karten Szenarien skripten und fahren!

    Im Map-Verzeichnis hat 4.162 lediglich einige Karten (default, flat und hmap) ergänzt.

  • Das wird funktionieren, bis Du eine Version deinstallierst. Dann werden auch gemeinsam genutzte Daten verschwinden, die müssen dann nachinstalliert werden. Geht alles - nur damit Du bescheid weißt.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Was mir gestern im "Einzelspieler" aufgefallen ist, wenn man auf der karte Artillerie anfordert, ist KEINE Artillerienummer und auch keine Zeitanzeige mehr in der karte zu sehen . Also GAR NICHTS. Ist also extremst schwer zu wissen, welche Artillerie man ggf NOCHMAL abrufen möchte oder WANN die Artillerie dort einschlägt. Das Gleiche gilt für gescriptete Artillerie. Es wird keine Zeitanzeige mehr eingeblendet, wann die Artillerie dort einschlägt.

    ( VERSCHLIMMBESSERT ?!? )

    Edit: OK, Frage wurde vorher schon gestellt. Realismus habe ich generell auf Hoch.


    Was mir in der Nachbesprechung auch aufgefallen ist, es sind teilweise nicht mehr alle Panzer in der Außenansicht zu finden.

    Laut karte stand ich 2m vor meinem Panzer, der aber nicht in der Außenansicht zu finden war.Auch im WBG war er dort nirgends zu finden. Aber dafür der Hubschrauber, den ich knapp 100m vor mir abgeschossen hatte.


    BUG?



    Beim Marder hatte ich rund 70 Schuss AP (DM 81) frontal auf einen BMP 2 abgefeuert, der nur knapp 250m vor mir stand. Hab den wirklich überall getroffen. Wannenunterseite, Turm, Kanone, etc, wurde aber nicht vernichtet. Ist die Munition "versehentlich" abgeschwächt worden???

    (letztlich musste ich den BMP mit nem Leo abschießen)



    Was wohl noch immer nicht geht, ist, das der Fahrer nicht mehr rausgucken kann. Vor 4.1 ging das IMMER. Beim Leopard 1 geht das komischerweise noch. Aber bei dem Leo 2 geht das seit der V4.1 nicht mehr. Wie das bei den anderen Fahrzeugen ist, habe ich bislang nicht geprüft.

  • Was mir gestern im "Einzelspieler" aufgefallen ist, wenn man auf der karte Artillerie anfordert, ist KEINE Artillerienummer und auch keine Zeitanzeige mehr in der karte zu sehen.

    Vielleicht sollte das im Einzelspielermodus nicht so sein; ich persönlich habe die alte Lösung auch bevorzugt. Allerdings war da immer das Problem, daß der Bezeichner immer an der korrekten Stelle war und es daher zu einfach war, von der Karte aus Schußkorrekturen durchzuführen. Wir finden aber, daß es stets beobachtetes Feuer sein sollte, und wer gründlich darüber nachdenkt, wird das auch nachvollziehen können (selbst wenn man die Meinung nicht teilt).


    Bei Wahl von mittlerem Realismus stellt sich die Frage nicht, daher habe ich mich bei dieser Änderung auf (starken) Wunsch der Betatester nicht quergelegt.

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?

  • Was mir in der Nachbesprechung auch aufgefallen ist, es sind teilweise nicht mehr alle Panzer in der Außenansicht zu finden.

    Laut karte stand ich 2m vor meinem Panzer, der aber nicht in der Außenansicht zu finden war.Auch im WBG war er dort nirgends zu finden. Aber dafür der Hubschrauber, den ich knapp 100m vor mir abgeschossen hatte.


    BUG?

    Schon möglich, aber aufgrund der Datenlage schwer zu untersuchen. Wenn so etwas auffällt, sollte dee AAR-Datei gespeichert und uns dann mit Angabe von Koordinate und Zeitstempel zugänglich gemacht werden (Karte und ggf. Szenario könnten auch benötigt werden).

    Bitte keine Privat-Nachrichten an mich!
    eMails integrieren sich viel besser in meinen Arbeitsablauf, oder schreibt's gleich ins Forum, OK?